Guten Morgen miteinander
Ich möchte meinen OpenWRT Router (TP-Link Archer C2600) durch eine pfSense ersetzen. Der OpenWRT Router soll ausschliesslich als Switch und Access Point fungieren.
Ein zusätzlicher managed Switch ist meiner Meinung nach nicht zwingend notwendig, da ausschliesslich zwei Geräte per Kabel mit dem Switch verbunden sind.
Zwischen der pfSense und dem OpenWRT-AP möchte ich nur ein Kabel verwenden, d.h. ich möchte mit einem VLAN-Trunk arbeiten und zwei VLANs definieren (LAN und IOT). Der Aufbau sieht ungefähr wie folgt aus:
DNS und DHCP erledigt die pfSense, zumindest den DHCP-Dienst würde ich auf dem OpenWRT-AP deaktivieren.
Nun bin ich mir leider nicht ganz sicher, wie ich den Switch auf dem OpenWRT-AP konfigurieren muss. Aktuell verwende ich einen speziellen Build von OpenWRT, bei welchem kein DSA aktiv ist. Als reiner Access Point ist dieser Build jedoch nicht zwingend notwendig. D.h., ich würde die offizielle Version von OpenWRT einspielen (Version 23.05.3). Ob in dieser Version DSA aktiv ist oder nicht, kann ich aktuell noch nicht sagen.
Im Spoiler ist eine Konfiguration aufgeführt, die meiner Meinung nach dem oben aufgeführten Setup entspricht. Ein Port wird als Trunk-Port definiert mit den beiden VLANs 10 und 20. Die restlichen drei Ports sind Access Ports (untagged) im VLAN 10. Das iot-Interface verfügt über keine IP-Adresse. Es handelt sich hierbei ausschliesslich um eine Layer-2-Erweiterung. Hat jemand von euch einen ähnlichen Aufbau im Einsatz und könnte derjenige die unten aufgeführte Konfiguration auf ihre Korrektheit überprüfen?
Vielen Dank für eure Antworten.
Viele Grüsse
Ich möchte meinen OpenWRT Router (TP-Link Archer C2600) durch eine pfSense ersetzen. Der OpenWRT Router soll ausschliesslich als Switch und Access Point fungieren.
Ein zusätzlicher managed Switch ist meiner Meinung nach nicht zwingend notwendig, da ausschliesslich zwei Geräte per Kabel mit dem Switch verbunden sind.
Zwischen der pfSense und dem OpenWRT-AP möchte ich nur ein Kabel verwenden, d.h. ich möchte mit einem VLAN-Trunk arbeiten und zwei VLANs definieren (LAN und IOT). Der Aufbau sieht ungefähr wie folgt aus:
DNS und DHCP erledigt die pfSense, zumindest den DHCP-Dienst würde ich auf dem OpenWRT-AP deaktivieren.
Nun bin ich mir leider nicht ganz sicher, wie ich den Switch auf dem OpenWRT-AP konfigurieren muss. Aktuell verwende ich einen speziellen Build von OpenWRT, bei welchem kein DSA aktiv ist. Als reiner Access Point ist dieser Build jedoch nicht zwingend notwendig. D.h., ich würde die offizielle Version von OpenWRT einspielen (Version 23.05.3). Ob in dieser Version DSA aktiv ist oder nicht, kann ich aktuell noch nicht sagen.
Im Spoiler ist eine Konfiguration aufgeführt, die meiner Meinung nach dem oben aufgeführten Setup entspricht. Ein Port wird als Trunk-Port definiert mit den beiden VLANs 10 und 20. Die restlichen drei Ports sind Access Ports (untagged) im VLAN 10. Das iot-Interface verfügt über keine IP-Adresse. Es handelt sich hierbei ausschliesslich um eine Layer-2-Erweiterung. Hat jemand von euch einen ähnlichen Aufbau im Einsatz und könnte derjenige die unten aufgeführte Konfiguration auf ihre Korrektheit überprüfen?
Vielen Dank für eure Antworten.
Viele Grüsse
with DSA:
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan0'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
config bridge-vlan
option device 'br-lan'
option vlan '10'
list ports 'lan0:t'
list ports 'lan1:u*'
list ports 'lan2:u*'
list ports 'lan3:u*'
config bridge-vlan
option device 'br-lan'
option vlan '20'
list ports 'lan0:t'
config interface 'lan'
option proto 'static'
option device 'br-lan.10'
option ipaddr '192.168.10.2'
option netmask '255.255.255.0'
option gateway '192.168.10.1'
config interface 'iot'
option proto 'none'
option device 'br-lan.20'
with swconfig:
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth1.10'
config device
option type 'bridge'
option name 'br-iot'
list ports 'eth1.20'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '10'
option vid '10'
option ports '0t 1 2 3 4t'
option description 'lan'
config switch_vlan
option device 'switch0'
option vlan '20'
option ports '0t 4t'
option description 'iot'
option vid '20'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.10.2'
option gateway '192.168.10.1'
config interface 'iot'
option proto 'none'
option device 'br-iot'
General settings:
--> disable DHCP (IPv4 and IPv6)
--> DNS-Server: Main Router
--> create the wireless networks and assign them to the corresponding interfaces
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan0'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
config bridge-vlan
option device 'br-lan'
option vlan '10'
list ports 'lan0:t'
list ports 'lan1:u*'
list ports 'lan2:u*'
list ports 'lan3:u*'
config bridge-vlan
option device 'br-lan'
option vlan '20'
list ports 'lan0:t'
config interface 'lan'
option proto 'static'
option device 'br-lan.10'
option ipaddr '192.168.10.2'
option netmask '255.255.255.0'
option gateway '192.168.10.1'
config interface 'iot'
option proto 'none'
option device 'br-lan.20'
with swconfig:
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth1.10'
config device
option type 'bridge'
option name 'br-iot'
list ports 'eth1.20'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '10'
option vid '10'
option ports '0t 1 2 3 4t'
option description 'lan'
config switch_vlan
option device 'switch0'
option vlan '20'
option ports '0t 4t'
option description 'iot'
option vid '20'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.10.2'
option gateway '192.168.10.1'
config interface 'iot'
option proto 'none'
option device 'br-iot'
General settings:
--> disable DHCP (IPv4 and IPv6)
--> DNS-Server: Main Router
--> create the wireless networks and assign them to the corresponding interfaces